Incident Overview
On April 21, 2024, a large number of new Facebook Message records were logged. Multiple copies of messages from the Messenger for Business chatbot were being provided as unique messages. Some users received hundreds of thousands of messages from the “Messenger for Business” chatbot, starting around 0600 UTC (Coordinated Universal Time), on April 21, 2024. All the messages were either "Here are a few topics that I can tell you about" or "Here are a few topics I can tell you about" but each had a unique ID. The Messages seem to all have gone into a single thread, and users said the messages arrived even when they didn't interact with the bot.
Example Messages
Impact
The influx of records led to widespread performance issues across the system, particularly affecting secondary processes.
Possible Cause
The incident coincides with the release of new Artificial Intelligence (AI) chatbots by Meta, suggesting a potential link to the increase in message records.
Support and Acknowledgement
Despite the timing and circumstances, there was no official confirmation from the Facebook Support Team regarding the cause of the incident (see the bug logged with Meta).
Resolution and Verification
The issue’s resolution was confirmed by manually reviewing archives to verify the resolution.
Documentation and Tagging
Posts affected by this issue are tagged with “i_04_4243”. Users wishing to view archives without these impacted message records can filter results using the incident tag “i_04_4243”.
Incident Timeline
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[Update] April 29, 2024
- Unanimous decision made by the Social Media Archiving Development, Product, and Customer Support Teams to apply an incident tag to affected records. Following this action, customers will be offered support with disposing of the records using the disposition system.
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[Update] April 25, 2024
- The Social Media Archiving Development Team discovers additional accounts impacted by the issue. However, no new chatbot messages were received, indicating the issue is no longer active. The Team believes Meta fixed their bug, marking the bug closed in Facebook’s support platform. Capture is enabled for all remaining Facebook Page accounts.
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[Update] April 24, 2024
- The Social Media Archiving Development Team enables capture for all Facebook Page accounts not specifically known to be impacted by this issue.
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[Update] April 23, 2024
- The Customer Support Team relays that a customer confirmed the messages from the chatbot stopped on April 22. Customers indicated receiving numerous notifications (messages) to their Facebook accounts.
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[Update] April 22, 2024
- Message capture is temporarily disabled for all Facebook Page accounts to mitigate system performance issues. The Social Media Archiving Development Team logs a bug with Facebook Support.
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[Start] April 21, 2024
- The Social Media Archiving Development Team reports “unusually high capture for Facebook page message replies yesterday afternoon, and have identified a handful of customers with new message threads that have tens of thousands of messages from "Messenger for Business". It seems to be a side effect of the new Meta chatbot. The records we're getting aren't duplicate capture in the usual way, Facebook is sending us a new network ID for every message, the messages just happen to be the same...”
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